Loading Issues

Some templates can have issues loading Muut when you open it via the main navigation. The reason this happens is due to Ajax loading not allowing Muut to initiate properly. Templates that may be affected are:

  • Brine, Clay, Feed, Foster, Greenwich, Hatch, Heights, Hunter, Hyde, Jaunt, Juke, Keene, Lincoln, Marta, Mercer, Mojave, Motto, Nueva, Rally, Rover, Sonora, Thorne
  • Farro, Haute
  • Skye, Foundry, Tudor - Blog landing page only
  • Tremont, Carson, Henson
  • York, Artesia, Harris, Lange, Jasper, Shibori, Taylor

Every template family here wont always have the issue, but in rare cases it's possible to have this loading problem on any of these themes.

Disable Ajax loading

Because Ajax loading causes the Muut script to not initialize the easiest and fastest solution is to disable this loading method.

There are exceptions though.

  • Ajax can't be disabled in Skye, Foundry, or Tudor.
  • Ajax can't be disabled on the blog landing page for Farro and Haute. If you uncheck Enable Ajax Loading in these templates, they will still use Ajax to load the Blog Page — meaning comments might still fail to load in some cases.

To disable Ajax:

  1. In the Home Menu, click Design, and then click Style Editor.
  2. Scroll down to Site: Loading.
  3. Uncheck Enable Ajax Loading.

Use link loading

This method will not work for Muut Comments
This method will not work inside of an "Index"

If you want to keep Ajax loading, or if you are unable to disable it, there is a second, more in depth method of allowing the Muut script to load.

  1. In the Home Menu, click Pages
  2. Click and drag your community page to the Not Linked category.
  3. Click on the + under your navigation menu and add a Link
  4. Enter the Link Title or name you want to appear on your navigation menu
  5. Use the External Link method and input the full URL of your community page on SquareSpace, including https://

That's it! You're good to go.